BỘ THÔNG TIN VÀ TRUYỀN THÔNG
CỘNG HÒA XÃ HỘI CHỦ NGHĨA VIỆT NAM
Độc lập - Tự do - Hạnh phúc
Số: 39/2017/TT-BTTTT
Hà Nội, ngày 15 tháng 12 năm 2017
THÔNG TƯ
Ban hành Danh mục tiêu chuẩn kỹ thuật
về ứng dụng công nghệ thông tin trong cơ quan nhà nước
Căn cứ Luật Công nghệ thông tin ngày 29 tháng 6 năm 2006;
Căn cứ Nghị định số 64/2007/NĐ-CP ngày 10 tháng 4 năm 2007 của Chính phủ về ứng dụng công nghệ thông tin trong hoạt động của cơ quan nhà nước;
Căn cứ Nghị định số 102/2009/NĐ-CP ngày 06 tháng 11 năm 2009 của Chính phủ về quản lý đầu tư ứng dụng công nghệ thông tin sử dụng nguồn vốn ngân sách nhà nước;
Căn cứ Nghị định số 17/2017/NĐ-CP ngày 17 tháng 02 năm 2017 của Chính phủ quy định chức năng, nhiệm vụ, quyền hạn và cơ cấu tổ chức của Bộ Thông tin và Truyền thông;
Theo đề nghị của Vụ trưởng Vụ Khoa học và Công nghệ,
Bộ trưởng Bộ Thông tin và Truyền thông ban hành Thông tư quy định Danh mục tiêu chuẩn kỹ thuật về ứng dụng công nghệ thông tin trong cơ quan nhà nước.
Điều 1. Ban hành kèm theo Thông tư này Danh mục tiêu chuẩn kỹ thuật về ứng dụng công nghệ thông tin trong cơ quan nhà nước (sau đây gọi là Danh mục).
Điều 2. Danh mục này bao gom các tiêu chuẩn bắt buộc áp dụng hoặc khuyến nghị áp dụng cho hệ thống thông tin của cơ quan nhà nước để bảo đảm kểt nối thông suốt, đồng bộ và khả năng chia sẻ, trao đổi thông tin an toàn, thuận tiện giừa các cơ quan nhà nước và giữa cơ quan nhà nước với tổ chức, cá nhân.
Danh mục này cũng được áp dụng để làm căn cứ trong hoạt động đầu tư ứng dụng công nghệ thông tin và thuê dịch vụ công nghệ thông tin sử dụng nguồn vốn ngân sách nhà nước.
Điều 3. Trong thời hạn 01 năm kể từ ngày Thông tư này có hiệu lực, hệ thống thông tin của cơ quan nhà nước đang hoạt động cần được rà soát và có phương án, lộ trình chuyển đổi, nâng cấp phù hợp với quy định tại Thông tư này.
Điều 4. Vụ Khoa học và Công nghệ có trách nhiệm chủ trì, phổi hợp với các đơn vị liên quan định kỳ rà soát, cập nhật Danh mục quy định tại Thông tư này.
Cục Tin học hóa có trách nhiệm hướng dần việc áp dụng các tiêu chuẩn kỹ thuật thuộc Danh mục quy định tại Thông tư này.
Điều 5. Thông tư này có hiệu lực thi hành kể từ ngày 01 tháng 7 năm 2018 và thay thể Thông tư sổ 22/2013/TT-BTTTT ngày 23 tháng 12 năm 2013 của Bộ trường Bộ Thông tin và Truyền thông ban hành Danh mục tiêu chuân kỳ thuật về ứng dụng công nghệ thông tin trong cơ quan nhà nước.
Điểu 6. Chánh Văn phòng, Vụ trưởng Vụ Khoa học và Công nghệ, Cục trưởng Cục Tin học hóa, Thủ trường các cơ quan, đơn vị thuộc Bộ, Giám đốc Sở Thông tin và Truyền thông các tỉnh, thành phố trực thuộc Trung ương, các tô chức và cá nhân có liên quan chịu trách nhiệm thi hành Thông tư này./.
BỘ TRƯỞNG
(Đã ký)
Trương Minh Tuấn
DANH MỤC TIÊU CHUẨN KỸ THUẬT
VÈ ỨNG DỤNG CÔNG NGHỆ THÔNG TIN TRONG CƠ QUAN NHÀ NƯỚC
(Ban hành kèm theo Thông tư số 39 /2017/TT-BTTTT ngày 15 tháng 12 năm 2017
của Bộ trưởng Bộ Thông tin và Truyền thông)
của Bộ trưởng Bộ Thông tin và Truyền thông')
Số
TT
Loại tiêu chuẩn
Ký hiệu tiêu chuẩn
Tền đầy đủ của tiêu chuẩn
Quy định áp dụng
1
Tiêu chuẩn về kết nối
1.1
Truyền siêu văn bản
HTTP vl.l
Hypertext Transíer Protocol version 1.1
Bắt buộc áp dụng
HTTP v2.0
Hypertext Transfer Protocol version 2.0
Khuyến nghị áp dụng
1.2
Truyền tệp tin
FTP
File Transíer Protocol
Bắt buộc áp dụng một hoặc cả hai tiêu chuẩn
HTTP vl.l
Hypertext Transĩer Protocol version 1.1
HTTP v2.0
Hypertext Transfer Protocol version 2.0
Khuyển nghị áp dụng
WebDAV
Web-based Distributed
Authoring and Versioning
Khuyến nghị áp dụng
1.3
Truyền, phát luồng âm thanh/ hình ảnh
RTSP
Real-time Streaming
Protocol
Khuyến nghị áp dụng
RTP
Real-time Transport Protocol
Khuyến nghị áp dụng
RTCP
Real-time Control Protocol
Khuyến nghị áp dụng
1.4
Truy cập và chia sẻ dữ liệu
OData v4
Open Data Protocol version 4.0
Khuyến nghị áp dụng
1.5
Truyền thư điện tử
SMTP/ MIME
Simple Mail Transfer Protocol/Multipurpose Internet Mail Extensions
Bắt buộc áp dụng
1.6
Cung cấp dịch vụ truy cập hộp thư điện tử
POP3
Post Office Protocol version 3
Bắt buộc áp dụng cả hai tiêu chuân đôi với máy chủ
IMAP 4revl
Internet Message Access
Protocol version 4 revision 1
1.7
Truy cập thư mục
LDAP v3
Lightweight Directory
Access Protocol version 3
Bắt buộc áp dụng
1.8
Dịch vụ tên miền
DNS
Domain Name System
Bắt buộc áp dụng
1.9
Giao vận mạng có kết nối
TCP
Transmission Control Protocol
Bẳt buộc áp dụng
1.10
Giao vận mạng không kết nối
UDP
User Datagram Protocol
Bắt buộc áp dụng
1.11
Liên mạng LAN/WAN
IPv4
Internet Protocol version 4
Bắt buộc áp dụng
IPv6
Internet Protocol version 6
Bẳt buộc áp dụng đôi với các thiết bị có kết nối Internet
1.12
Mạng cục bộ không dây
IEEE
802.1 Ig
Institute of Electrical and Electronics Engineers Standard (IEEE) 802.1 Ig
Bất buộc áp dụng
IEEE
802.1 In
Institute of Electrical and Electronics Engineers Standard (IEEE) 802.1 In
Khuyến nghị áp dụng
1.13
Truy cập Internet với thiết bị không dây
WAP v2.0
Wireless Application Protocol version 2.0
Bắt buộc áp dụng
1.14
Dịch vụ Web dạng SOAP
SOAP vl.2
Simple Object Access
Protocol version 1.2
Bẳt buộc áp dụng một, hai hoặc cả ba tiêu chuẩn
WSDL
V2.0
Web Services Description Language version 2.0
UDDI v3
Universal Description, Discovery and Integration version 3
1.15
Dịch vụ Web dạng RESTíul
RESTíul web Service
Representational State transíer
Khuyến nghị áp dụng
1.16
Dịch vụ đặc tả Web
ws BPEL v2.0
Web Services Business Process Execution Language Version 2.0
Khuyến nghị áp dụng
WS-I Simple SOAP Binding Proíìle Version 1.0
Simple SOAP Binding
Proíĩle Version 1.0
Khuyến nghị áp dụng
WS- Federation vl.2
Web Services Federation
Language Version 1.2
Khuyến nghị áp dụng
ws-
Addressing vl.o
Web Services Addressing 1.0
Khuyến nghị áp dụng
ws-
Coordination
Version 1.2
Web Services Coordination
Version 1.2
Khuyến nghị áp dụng
WS-Policy vl.2
Web Services Coordination
Version 1.2
Khuyến nghị áp dụng
OASIS Web Services Business Activity Version 1.2
Web Services Business Activity Version 1.2
Khuyến nghị áp dụng
ws-
Discovery
Version 1.1
Web Services Dynamic Discovery Version 1.1
Khuyển nghị áp dụng
ws-
MetadataExc hange
Web Services Metadata Exchange
Khuyến nghị áp dụng
1.17
Dịch vụ đồng bộ thời gian
NTPv3
Network. Time Protocol version 3
Bắt buộc áp dụng một trong hai tiêu chuẩn
NTPv4
Network Time Protocol version 4
2
Tiêu chuẩn về tích họp dù'
iệu
2.1
Ngôn ngừ định dạng văn bản
XML vl.o (5lh Edition)
Extensible Markup Language version 1.0 (5th Edition)
Bắt buộc áp dụng một trong hai tiêu chuẩn
XML vl.l (2nd Edition)
Extensible Markup
Language version 1.1
2.2
Ngôn ngừ định dạng văn bản cho giao dịch điện tử
ISO/TS 15000:2014
Electronic Business Extensible Markup Language (ebXML)
Bắt buộc áp dụng
2.3
Định nghía các lược đồ trong tài liệu XML
XML Schema
VI.1
XML Schenia version 1.1
Bẳt buộc áp dụng
2.4
Biến đôi dừ liệu
XSL
Extensible Stylesheet
Language
Bất buộc áp dụng phiên bản mới nhất.
2.5
Mô hình hóa đổi tượng
UML v2.5
Ưniíied Modelling Language version 2.5
Khuyến nghị áp dụng
2.6
Mô tà tài nguyên dừ liệu
RDF
Resource Description Framework
Khuyến nghị áp dụng
0WL
Web Ontology Language
Khuyến nghị áp dụng
2.7
Trình diễn bộ kí tự
UTF-8
8-bit Universal Character Set
(ucsyunicode
Transíormation Format
Bắt buộc áp dụng
2.8
Khuôn thức trao đôi thông tin địa lý
GML v3.3
Geography Markup
Language version 3.3
Bắt buộc áp dụng
2.9
Truy cập và cập nhật các thông tin địa lý
WMS vl.3.0
OpenGIS Web Map Service version 1.3.0
Bẳt buộc áp dụng
WFS vl.1.0
Web Feature Service version
1.1.0
Bắt buộc áp dụng
2.10
Trao đổi dữ liệu đặc tả tài liệu XML
XMI V2.4.2
XML Metadata Interchange version 2.4.2
Khuyến nghị áp dụng
2.11
sồ đăng ký siêu dừ liệu (MDR)
ISO/IEC 11179:2015
Sổ đăng ký siêu dữ liệu (Metadata registries - MDR)
Khuyến nghị áp dụng
2.12
Bộ phần tử siêu dữ liệu Dublin Core
ISO 15836- 1:2017
Bộ phần tử siêu dừ liệu
Dublin Core
Khuyến nghị áp dụng(*)
2.13
Định dạng trao đổi dừ liệu mô tả đối tượng dạng kịch bàn JavaScript
JSON RFC7159
JavaScript Object Notation
Khuyến nghị áp dụng
2.14
Ngôn ngữ mô hình quy trình nghiệp vụ
BPMN 2.0
Business Process Model and
Notation version 2.0
Khuyến nghị áp dụng
3
Tiêu chuẩn về truy cập thông tin
3.1
Chuẩn nội dung Web
HTML V4.01
Hypertext Markup Language version 4.01
Bất buộc áp dụng
WCAG 2.0
W3C Web Content Accessibility Guidelines (WCAG) 2.0
Khuyến nghị áp dụng
HTML 5
Hypertext Markup Language version 5
Khuyến nghị áp dụng
3.2
Chuẩn nội dung Web mở rộng
XHTML vl.l
Extensible Hypertext Markup Language version 1.1
Bắt buộc áp dụng
3.3
Giao diện người dùng
CSS2
Cascading Style Sheets
Language Level 2
Bẳt buộc áp dụng một trong ba tiêu chuân
CSS3
Cascading Style Sheets
Language Level 3
XSL
Extensible Stylesheet Language version
(*) Đối với càc đối tượng thuộc phạm vi điều chinh của Thông tư số 24/2011/TT-BTTTT thì vẫn áp dụng quy định cùa Thông tư số 24/2011/TT-BÌ ITT.
3.4
Văn bản
(.txt)
Định dạng Plain Text (.txt): Dành cho các tài liệu cơ bản không có cấu trúc
Bắt buộc áp dụng
(.rtf)vl.8, V 1.9.1
Định dạng Rích Text (.rtf) phiên bản 1.8, 1.9.1: Dành cho các tài liệu có thể trao đôi giữa các nền khác nhau
Bẳt buộc áp dụng
(.docx)
Định dạng văn bản Word mở rộng của Microsoíì (.docx)
Khuyến nghị áp dụng
(,pdf) vl.4, vl.5, vl.6, vl.7
Định dạng Portable Document (.pdí) phiên bàn 1.4, 1.5, 1.6, 1.7: Dành cho các tài liệu chi đọc
Bất buộc áp dụng một, hai hoặc cả ba tiêu chuẩn
(.doc)
Định dạng văn bản Word cùa Microsoh (.doc)
(.odt) vl.2
Định dạng Open Document
Text (.odt) phiên bản 1.2
3.5
Bàng tính
(.csv)
Định dạng Comma eparated Variable/Delimited (.csv): Dành cho các bảng tính cần trao đổi giữa các ứng dụng khác nhau.
Bắt buộc áp dụng
(.xlsx)
Định dạng bảng tính Excel mờ rộng cùa Microsoft (.xlsx)
Khuyến nghị áp dụng
(.xls)
Định dạng bảng tính Excel của Microsoữ (.xls)
Bắt buộc áp dụng một hoặc cả hai tiêu chuẩn
(.ods) vl .2
Định dạng Open Document Spreadsheets (.ods) phiên bản 1.2
3.6
Trình diễn
(.htm)
Định dạng Hypertext Document (.htm): cho các trình bày được trao đôi thông qua các loại trình duyệt khác nhau
Bắt buộc áp dụng
(.pptx)
Định dạng PovverPoint mở rộng của Microsotì (.pptx)
Khuyến nghị áp dụng
(.pdí)
Định dạng Portable Document (.pdf): cho các trình bày lưu dưới dạng chỉ đọc
Bẳt buộc áp dụng một, hai hoặc cả ba tiêu chuẩn
(•ppt)
Định dạng PowerPoint (.ppt) của Microsoíì
(.odp) vl.2
Định dạng Open Document Presentation (.odp) phiên bản 1.2
3.7
Ảnh đồ họa
JPEG
Joint Photographic Expert Group (,jpg)
Bẳt buộc áp dụng một, hai, ba hoặc cả bốn tiêu chuẩn
GIF v89a
Graphic Interchange (.gií) version 89a
TIFF
Tag Image File (.tif)
PNG
Portable Network Graphics (.png)
3.8
Ảnh gắn với toạ độ địa lý
GEO TIFF
Tagged Image File Format for GIS applications
Bắt buộc áp dụng
3.9
Phim ảnh, âm thanh
MPEG-1
Moving Picture Experts Group-1
Khuyến nghị áp dụng
MPEG-2
Moving Picture Experts
Group-2
Khuyến nghị áp dụng
MPEG-4
Moving Picture Experts
Group-4
Khuyến nghị áp dụng
MP3
MPEG-1 Audio Layer 3
Khuyến nghị áp dụng
AAC
Advanced Audio Coding
Khuyến nghị áp dụng
3.10
Luồng phim ảnh, âm thanh
(.así), (.wma), (,wmv)
Các định dạng cùa Microsoíì Windows Media Player (.asf), (.wma), (.wmv)
Khuyến nghị áp dụng
(.ra), (.rm), (.ram), (.rmm)
Các định dạng Real Audio/Real Video (.ra), (,rm), (.ram), (.rmm)
Khuyến nghị áp dụng
(.avi), (.mov), (•qt)
Các định dạng Apple Quicktime (.avi), (.mov), Gqt)
Khuyến nghị áp dụng
3.11
Hoạt họa
GIF v89a
Graphic Interchange (.gií) version 89a
Khuyến nghị áp dụng
(.swf)
Định dạng Macromedia Flash (.swf)
Khuyến nghị áp dụng
(.swf)
Định dạng Macromedia Shockvvave (.swf)
Khuyến nghị áp dụng
(.avi), (.qt), (.mov)
Các định dạng Apple
Quicktime (.avi),(.qt),(.mov)
Khuyến nghị áp dụng
3.12
Chuân nội dung cho thiết bị di động
WML v2.0
Wireless Markup Language version 2.0
Bắt buộc áp dụng
3.13
Bộ ký tự và mà hóa
ASCII
American Standard Code for Iníồrmation Interchange
Bất buộc áp dụng
3.14
Bộ ký tự và mà hóa cho tiếng Việt
TCVN 6909:2001
TCVN 6909:2001 “Công nạhệ thông tin - Bộ mà ký tự tiếng Việt 16-bit”
Bắt buộc áp dụng
3.15
Nén dữ liệu
Zip
Zip (.zip)
Bẳt buộc áp dụng một hoặc cả hai tiêu chuẩn
.gz v4.3
GNU Zip (.gz) version 4.3
3.16
Ngôn ngừ kịch bản phía trinh khách
ECMA 262
ECMAScript version 6 (6th Edition)
Bắt buộc áp dụng
3.17
Chia sẻ nội dung Web
RSS vl.o
RDF Site Summary version 1.0
Bẳt buộc áp dụng một trong hai tiêu chuân
RSS v2.0
Really Simple Syndication version 2.0
ATOM vl.o
ATOM version 1.0
Khuyến nghị áp dụng
3.18
Chuẩn kết noi ứng dụng cổng thông tin diện tử
JSR 168
Java Speciíĩcation Requests 168 (Portlet Speciĩication)
Bat buộc áp dụng
JSR 286
Java Speciíìcation Requests 286 (Portlet Speciíìcation)
Khuyến nghị áp dụng
WSRP vl.o
Web Services for Remote
Portlets version 1.0
Bất buộc áp dụng
WSRP v2.0
Web Services for Remote Portlets version 2.0
Khuyến nghị áp dụng
4
Tiêu chuẩn về an toàn thông tin
4.1
An toàn thư điện từ
S/MIME v3.2
Secure Multi-purpose Internet Mail Extensions version 3.2
Bất buộc áp dụng
OpenPGP
OpenPGP
Khuyến nghị áp dụng
4.2
An toàn tầng giao vận
SSH v2.0
Secure Shell version 2.0
Bắt buộc áp dụng
TLS V1.2
Transport Layer Security version 1.2
Bắt buộc áp dụng
4.3
An toàn truyền tệp tin
HTTPS
Hypertext Transfer Protocoỉ Secure
Bắt buộc áp dụng
FTPS
File Transíer Protocol Secure
Khuyển nghị áp dụng
SFTP
SSH File Transfer Protocol
Khuyến nghị áp dụng
4.4
An toàn truyền thư điện tử
SMTPS
Simple Mail Transfer
Protocol Secure
Bat buộc áp dụng
4.5
An toàn dịch vụ truy cập hộp thư
POP3S
Post Office Protocol version 3 Secure
Bắt buộc áp dụng một hoặc cả hai tiêu chuẩn
IMAPS
Internet Message Access
Protocol Secure
4.6
An toàn dịch vụ DNS
DNSSEC
Domain Name System Securỉty Extenssions
Khuyến nghị áp dụng
4.7
An toàn tâng mạng
IPsec - IP ESP
Internet Protocol security với IPESP
Bắt buộc áp dụng
4.8
An toàn thông tin cho mạng không dây
WPA2
Wi-fi Protected Access 2
Bắt buộc áp dụng
4.9
Giải thuật mã hóa
TCVN
7816:2007
Công nghệ thông tin. Kỹ thuật mật mã thuật toán mã dữ liệu AES
Khuyến nghị áp dụng
3DES
Triple Data Encryption Standard
Khuyến nghị áp dụng
PKCS#1
V2.2
RSA Cryptography Standard - version 2.2
Khuyến nghị áp dụng, sử dụng tược đồ RSAES-OAEP để mã hóa
ECC
Elliptic Curve Cryptography
Khuyến nghị áp dụng
4.10
Giài thuật chừ ký sổ
PKCS#1
V2.2
RSA Cryptography Standard - version 2.2
Bắt buộc áp dụng, sử dụng lược đồ RSASSA-PSS để ký
ECDSA
Elliptic Curve Digital Signature Algorithm
Khuyến nghị áp dụng
4.11
Giải thuật băm cho chừ ký số
SHA-2
Secure Hash Algorithms-2
Khuyến nghị áp dụng
4.12
Giải thuật truyền khóa
RSA-KEM
Rivest-Shamir-Adleman - KEM (Key Encapsulation Mechanism) Key Transport Algorithm
Bắt buộc áp dụng
ECDHE
Elliptic Curve Diffie Hellman Ephemeral
Khuyến nghị áp dụng
4.13
Giải pháp xác thực người sử dụng
SAML v2.0
Security Assertion Markup Language version 2.0
Khuyển nghị áp dụng
4.14
An toàn trao đổi bản tin XML
XML Encryption Syntax and Processing
XML Encryption Syntax and Processing
Bắt buộc áp dụng
XML Signature Syntax and Processing
XML Signature Syntax and Processing
Bắt buộc áp dụng
4.15
Quản lý khóa công khai bản tin XML
XKMS v2.0
XML Key Management Speciíìcation version 2.0
Khuyến nghị áp dụng
4.16
Giao thức an toàn thông tin cá nhân
P3P vl.l
Platíorm for Privacy Preferences Project
version 1.1
Khuyến nghị áp dụng
4.17
Hạ tầng khóa công khai
Khuyến nghị áp dụng
Cú pháp thông điệp mật mã cho ký, mà hóa
PKCS//7 vl.5 (RFC 2315)
Cryptographic message syntax for íile-based signing and encrypting version 1.5
Cú pháp thông tin thẻ mật mã
PKCS#15 vl.l
Cryptographic token iníormation syntax version 1.1
Cú pháp thông tin khóa riêng
PKCS#8
VI.2 (RFC 5958)
Private-Key Iníồrmation
Syntax Standard version 1.2
Giao diện thẻ mật mà
PKCS#11
V2.20
Cryptographic token interíace Standard version 2.20
Cú pháp trao đổi thông tin cá nhân
PKCS#12 vl.l
Personal Iníormation Exchange Syntax version 1.1
Khuôn dạng danh sách chứng thư sổ thu hồi
RFC 5280
Certiíicate Revocation List Proíìle
Khuôn dạng chứng thư số
RFC 5280
Public Key Inírastructure Certiíìcate
Cú pháp yêu cẩu chứng thực
PKCS#10 vl.7(RFC 2986)
Certiíìcation Request Syntax Speciíication version 1.7
Giao thức trạng thái chứng thư trực tuyến
RFC 6960
On-line Certiíìcate status protocol
Giao thức găn tem thời gian
RFC3161
Time stamping protocol
Dịch vụ tem thời gian
ISO/IEC 18014-1:2008
ISO/IEC 18014-2:2009
ISO/IEC 18014-3:2009
ISO/IEC 18014-4:2015
Iníồrmation technology Security techniques - Time stamping Services Part 1: Framework Part 2: Mechanisms producing independent tokens
Part 3: Mechanisms producing linked tokens Part 4: Traceability of time sources
4.18
An toàn cho dịch vụ Web
WS-Security vl.1.1
Web Services Security: SOAP Message Security
Version 1.1.1
Khuyến nghị áp dụng
4.19
Khuôn dạng dữ liệu trao đổi sự cố an toàn mạng
RFC 7970
The Incident Object Description Exchange Format version 2 (IODEF)
Khuyến nghị áp dụng